Eclipse & Ant: Specified VM install not found

Falls ihr in Eclipse beim Starten eines Ant-Tasks die folgende oder eine ähnliche Meldung erhaltet: „Specified VM install not found: type Standard VM, name java…“ liegt dies vermutlich an veralteten Run-Configurations in Eclipse. Das einfachste ist diese einfach direkt zu löschen. Als erstes solltet ihr Eclipse schließen. Dann geht ihr in das Verzeichnis eures Workspaces (dort wo Eclipse Metadaten und Projekte von euch abspeichert) und navigiert dort in den folgenden Ordner:

[...]\.metadata\.plugins\org.eclipse.debug.core\.launches

Dort löscht ihr alle vorhandenen Dateien, fertig. Wenn ihr Eclipse jetzt neustartet sollte die Fehlermeldung nicht mehr erscheinen und der Ant-Task kann problemlos ausgeführt werden.

Hinweis: Ihr löscht damit nur die Run-/Debug-Configurations. Das ist im Normalfall nicht weiter schlimm und stört keinen.

3 Gedanken zu „Eclipse & Ant: Specified VM install not found

  • 8. August 2011 um 10:54
    Permalink

    Danke!

    Als C# Entwickler war ich grad ziemlich aufgeschmissen :-)

    Antworten
  • 13. Juni 2012 um 11:18
    Permalink

    Super Tipp! Danke. Das hat uns viel Zeit gespart.

    Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Durch die weitere Nutzung der Seite stimmst du der Verwendung von Cookies zu. Weitere Informationen zum Datenschutz...

Die Cookie-Einstellungen auf dieser Website sind auf "Cookies zulassen" eingestellt, um das beste Surferlebnis zu ermöglichen. Wenn du diese Website ohne Änderung der Cookie-Einstellungen verwendest oder auf "Akzeptieren" klickst, erklärst du sich damit einverstanden.

Schließen